I can see a few issues in the log from your VM:

1. Buggy audio in the VM's kernel driver (says pulseaudio):

jul 05 11:05:21 VM-Xubuntu-2004 pulseaudio[1406]: ALSA woke us up to write new 
data to the device, but there was actually nothing to write.
jul 05 11:05:21 VM-Xubuntu-2004 pulseaudio[1406]: Most likely this is a bug in 
the ALSA driver 'snd_hda_intel'. Please report this issue to the ALSA 
developers.
jul 05 11:05:21 VM-Xubuntu-2004 pulseaudio[1406]: We were woken up with POLLOUT 
set -- however a subsequent snd_pcm_avail() returned 0 or another value < 
min_avail.
jul 05 11:05:21 VM-Xubuntu-2004 pulseaudio[1406]: Disabling timer-based 
scheduling because running inside a VM.

2. More problems with the VM's kernel driver:

jul 05 11:05:28 VM-Xubuntu-2004 pulseaudio[1406]: Unable to set sw params: 
Permission denied
jul 05 11:05:28 VM-Xubuntu-2004 pulseaudio[1406]: Failed to set software 
parameters: Permission denied
jul 05 11:05:28 VM-Xubuntu-2004 pulseaudio[1406]: Error opening PCM device 
front:0: No such file or directory
jul 05 11:05:28 VM-Xubuntu-2004 systemd[1399]: pulseaudio.service: Succeeded.

3. A couple of kernel crashes apparently relating to running out of
memory in the VM.

So I suggest:

  * Giving the VM more memory.
  * Running fewer apps in the VM.
  * Configuring the VM with a different type of virtual audio device (if you 
can).


** Package changed: pulseaudio (Ubuntu) => linux (Ubuntu)

** Changed in: linux (Ubuntu)
       Status: Incomplete => New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1886330

Title:
  pulseaudio not working in Virtualbox

Status in linux package in Ubuntu:
  New

Bug description:
  I run my "work" VMs and in Xubuntu pulse audio often does not start.
  In this dump I tried to start music through Firefox and through my
  media player quodlibet and none of the audio starts.

  See attachment with the pulseaudio volume control and quodlibet stuck
  on time 0:00 like Firefox.

  I do not have the problem with plain Ubuntu, Ubuntu Mate nor with
  Ubuntu Studio.

  The problem is annoying, because I use Xubuntu for office and
  communication like Email and the WhatsApp/Firefox/ICE combination and
  with this bug WhatsApp is useless.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: pulseaudio 1:13.99.1-1ubuntu3.3
  ProcVersionSignature: Ubuntu 5.4.0-40.44-generic 5.4.44
  Uname: Linux 5.4.0-40-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.3
  Architecture: amd64
  AudioDevicesInUse:
   USER        PID ACCESS COMMAND
   /dev/snd/controlC0:  bertadmin   1490 F.... pulseaudio
   /dev/snd/pcmC0D0c:   bertadmin   1490 F...m pulseaudio
   /dev/snd/pcmC0D0p:   bertadmin   1490 F...m pulseaudio
   /dev/snd/timer:      bertadmin   1490 f.... pulseaudio
  CasperMD5CheckResult: skip
  CurrentDesktop: XFCE
  Date: Sun Jul  5 11:33:48 2020
  InstallationDate: Installed on 2018-03-11 (847 days ago)
  InstallationMedia: Xubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180310)
  SourcePackage: pulseaudio
  UpgradeStatus: Upgraded to focal on 2020-03-04 (122 days ago)
  dmi.bios.date: 12/01/2006
  dmi.bios.vendor: innotek GmbH
  dmi.bios.version: VirtualBox
  dmi.board.name: VirtualBox
  dmi.board.vendor: Oracle Corporation
  dmi.board.version: 1.2
  dmi.chassis.type: 1
  dmi.chassis.vendor: Oracle Corporation
  dmi.modalias: 
dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
  dmi.product.family: Virtual Machine
  dmi.product.name: VirtualBox
  dmi.product.version: 1.2
  dmi.sys.vendor: innotek GmbH

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1886330/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to