the dmesg in the #1 is not a complete one, could you please upload a new
one (remove the "snd-intel-dspcfg.dsp_driver=1").

BTW, could you please try the kernel older than 5.4.0-40.44-generic like

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.

  [Vostro 5490, Realtek ALC3204, Speaker, Internal] Pulseaudio fails to
  detect card

Status in pulseaudio package in Ubuntu:

Bug description:
  I have ubuntu Ubuntu 20.04 LTS installed, together with windows (dual boot) 
on my laptop. 
  There is no sound at all, seems like Pulseaudio / Alsa dont recognize the 
sound card:

  $ pacmd list-cards
  0 card(s) available.

  dmesg shows errors of sof-audio-pci:

  $ dmesg

  [   13.313523] sof-audio-pci 0000:00:1f.3: error: hw params ipc failed for 
stream 2
  [   13.313524] sof-audio-pci 0000:00:1f.3: ASoC: 0000:00:1f.3 hw params 
failed: -22
  [   13.313525]  HDA Analog: ASoC: hw_params FE failed -22
  [   13.313883] sof-audio-pci 0000:00:1f.3: error: ipc error for 0x60010000 
size 20
  [   13.313884] sof-audio-pci 0000:00:1f.3: error: hw params ipc failed for 
stream 2
  [   13.313884] sof-audio-pci 0000:00:1f.3: ASoC: 0000:00:1f.3 hw params 
failed: -22
  [   13.313885]  HDA Analog: ASoC: hw_params FE failed -22
  [   13.314249] sof-audio-pci 0000:00:1f.3: error: ipc error for 0x60010000 
size 20
  [   13.314249] sof-audio-pci 0000:00:1f.3: error: hw params ipc failed for 
stream 2
  [   13.314250] sof-audio-pci 0000:00:1f.3: ASoC: 0000:00:1f.3 hw params 
failed: -22
  [   13.314250]  HDA Analog: ASoC: hw_params FE failed -22
  [10706.102325] sof-audio-pci 0000:00:1f.3: error: no reply expected, received 

  pci device:
  $ lspci -nnk
  00:1f.3 Multimedia audio controller [0401]: Intel Corporation Device 
        Subsystem: Dell Device [1028:0959]
        Kernel driver in use: sof-audio-pci
        Kernel modules: snd_hda_intel, snd_sof_pci

  There was actually already a sound problem when I had ubuntu 18.04 -
  The sound worked after ubuntu got up, but then at some point the sound
  just died, with some different messages on dmesg. I upgraded the
  kernel and ubuntu version in hope it will solve the problem, but seems
  like it only got worse.

  Sound works in windows on the same laptop without issues.

  My attempts so far, which didnt yield anything
  1. reinstall and upgrae linux-firmware. currently 
'linux-firmware/focal-updates,focal-updates,now 1.187.1 all [installed]'
  2. adding those line to /etc/modprobe.d/alsa-base.conf:
   options snd-hda-intel model=auto
   options snd-hda-intel dmic_detect=0

  also, when I run 'alsa force-reload' the system just totally crashes,
  forcing me to press the power button to shut it off.

  Extra info

  $ inxi -Fxlpoz

  System:    Kernel: 5.4.0-40-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
Desktop: Gnome 3.36.2 
             Distro: Ubuntu 20.04 LTS (Focal Fossa) 
  Machine:   Type: Laptop System: Dell product: Vostro 5490 v: N/A serial: 
             Mobo: Dell model: 05P6R7 v: A00 serial: <filter> UEFI: Dell v: 
1.5.1 date: 01/14/2020 
  Battery:   ID-1: BAT0 charge: 40.7 Wh condition: 40.7/42.0 Wh (97%) model: 
SMP DELL VM73283 status: Full 
  CPU:       Topology: Quad Core model: Intel Core i5-10210U bits: 64 type: MT 
MCP arch: Kaby Lake rev: C L2 cache: 6144 KiB 
             flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
bogomips: 33599 
             Speed: 600 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 600 2: 
600 3: 600 4: 600 5: 600 6: 600 7: 600 8: 600 
  Graphics:  Device-1: Intel UHD Graphics vendor: Dell driver: i915 v: kernel 
bus ID: 00:02.0 
             Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: 
             resolution: 1920x1080~60Hz, 1920x1080~60Hz, 1920x1080~60Hz 
             OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 
20.0.4 direct render: Yes 
  Audio:     Device-1: Intel vendor: Dell driver: sof-audio-pci bus ID: 00:1f.3 
             Sound Server: ALSA v: k5.4.0-40-generic 
  Network:   Device-1: Intel Wireless-AC 9462 driver: iwlwifi v: kernel port: 
4000 bus ID: 00:14.3 
             IF: wlp0s20f3 state: up mac: <filter> 
             Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
vendor: Dell driver: r8169 v: kernel port: 3000 
             bus ID: 01:00.0 
             IF: enp1s0 state: down mac: <filter> 
  Drives:    Local Storage: total: 476.94 GiB used: 173.69 GiB (36.4%) 
             ID-1: /dev/nvme0n1 vendor: Toshiba model: KBG40ZNS512G NVMe 512GB 
size: 476.94 GiB

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: pulseaudio 1:13.99.1-1ubuntu3.3
  ProcVersionSignature: Ubuntu 5.4.0-40.44-generic 5.4.44
  Uname: Linux 5.4.0-40-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.3
  Architecture: amd64
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', 
'/dev/snd/controlC0', '/dev/snd/hwC0D0', '/dev/snd/hwC0D2', 
'/dev/snd/pcmC0D5p', '/dev/snd/pcmC0D4p', '/dev/snd/pcmC0D3p', 
'/dev/snd/pcmC0D1c', '/dev/snd/pcmC0D1p', '/dev/snd/pcmC0D0c', 
'/dev/snd/pcmC0D0p', '/dev/snd/pcmC0D7c', '/dev/snd/pcmC0D6c', '/dev/snd/seq', 
'/dev/snd/timer'] failed with exit code 1:
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Tue Jul  7 14:36:30 2020
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
  InstallationDate: Installed on 2019-10-29 (251 days ago)
  InstallationMedia: Ubuntu 18.04 "Bionic" - Build amd64 LIVE Binary 
  SourcePackage: pulseaudio
  Symptom: audio
  Symptom_Card: sof-hda-dsp - sof-hda-dsp
  Symptom_Jack: Speaker, Internal
  Title: [Vostro 5490, Realtek ALC3204, Speaker, Internal] Pulseaudio fails to 
detect card
  UpgradeStatus: Upgraded to focal on 2020-06-25 (11 days ago)
  dmi.bios.date: 01/14/2020
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.5.1
  dmi.board.name: 05P6R7
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.product.family: Vostro
  dmi.product.name: Vostro 5490
  dmi.product.sku: 0959
  dmi.sys.vendor: Dell Inc.
  modified.conffile..etc.pulse.default.pa: [modified]
  mtime.conffile..etc.pulse.default.pa: 2020-07-02T14:15:41.001282

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to