*** This bug is a duplicate of bug 1871794 ***

Noticed that I couldn't use my headset mic on any apps in the past month, but 
the above reports are describing the same behavioural issues as I am seeing soI 
think I am hitting the same problem.
Using Sennheisser HD 4.40BT headphones on a System76 Gazelle. Connects default 
audio through headphones with the A2DP profile as expected when connecting 
through BT, but the Internal Microphone stays selected for input. Trying to 
select the HD4.4 microphone setting does nothing, and no signal of any kind 
comes through the input.

Switching to the HFP/HSP profile also leads to a break in audio, and
after the A2DP setting is shown as unavailable until I wipe the userland
pulse configs. It cuts off the audio through the headset and ends up in
a bad configuration where I have to turn BT off and on again to
reconnect and when it does, the configuration is stuck on HFP/HSP and in

No audio through the headset mic can be picked up through any
pulseaudio-enabled monitors, all showing zero input with whatever
configuration or set-up I can muster.

Running Linux pop-os 5.4.0-7642-generic #46~1598628707~20.04~040157c-
Ubuntu SMP Fri Aug 28 18:02:16 UTC  x86_64

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.

  [Sennheiser HD 4.50 BTNC] Bluetooth headset not working when selecting
  HSP/HFP audio profile in Focal Fossa

Status in bluez package in Ubuntu:
Status in pulseaudio package in Ubuntu:

Bug description:
  After updating the release from Ubuntu 19.10 to 20.04, the bluetooth
  headset doesn't work anymore when HSP/HFP profile is selected.

  With Ubuntu 19.10 the headset was working, there was audio and the mic
  was perfect for video conferencing.

  [Steps to reproduce]
  1. Connect headset (used blueman to setup and connect)
  1.1. When connected the system automatically selects A2DP profile
  2. Start playing audio (browser or other)
  3. Change profile to HSP/HFP with pavucontrol (or blueman)
  4. The audio disappears and microphone is not working (no input)
  5. Optionally switch back to A2DP and the audio comes back

  When switching to HSP/HFP the audio should keep playing and the microphone 
should start working

  I tried with pavucontrol to switch between profiles while playing audio from 
a browser.
  As side note there's a led in the headset that still blinks when switching 

  I tried deleting the pulse folder under user's profile .config without
  success, also reinstalled packages and did a `sudo alsa force-reload`
  and rebooting several times.

  Note: not sure this is a duplicate of [Bug #1576559], it looks quite
  different since the profile changes but the headset stops working.

  [System info]
  Ubuntu: 20.04 - Linux 5.4.0-29-generic x86_64
  pulseaudio: 1:13.99.1-1ubuntu3
  bluez: 5.53-0ubuntu3

  Headset: Sennheiser HD 4.50 BTNC

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to