Here's my guess:

$ echo "l(2875204834)/l(2)" | bc -ql
31.42101759351087610555


Package: dotnet-sdk-6.0-source-built-artifacts
Architecture: amd64
Version: 6.0.111-0ubuntu3
Priority: optional
Section: universe/devel
Source: dotnet6
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-disc...@lists.ubuntu.com>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 2846146
Filename: 
pool/universe/d/dotnet6/dotnet-sdk-6.0-source-built-artifacts_6.0.111-0ubuntu3_amd64.deb
Size: 2875204834
MD5sum: 8f245b799d02fc637a871183d161273a
SHA1: 29728e493a97811bd1f6a25d93dd9a76bc3c95e5
SHA256: 1429baab871dfb2ba2717c99ccd55379c1a41eb75f0eb311faf18b23475f9938
SHA512: 
20e5ae0ff1427ccfdf930a64aac419c66d4567420e31de6367d9d7e2aef1e6f0e47f0980fc6d5f44e70f1c1be20e56fb8a034d2022405281eaa9ca520b361d73
Homepage: https://dot.net/core
Description: Internal package for building dotNet 6.0 Software Development Kit
Description-md5: c5f0dc17274bcdd68c9a9d09b85e6a60

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/1998265

Title:
  OverFlow error when using cnf-extractor

Status in apt package in Ubuntu:
  New
Status in apt source package in Bionic:
  New

Bug description:
  I'm trying to update the command-not-found indexes (bin/cnf-extract.py
  $MIRROR $suite $component $arch) on the production cnf extractor
  system (running bionic) and have encountered Tracebacks when
  generating them for Jammy and Lunar. This is causing the command not
  found indexes to be out of date for all(?) releases of Ubuntu.

  The lunar failure:

  Get:1 dotnet-sdk-6.0_6.0.111-0ubuntu3_amd64.deb [79.1 MB]
  Fetched 79.1 MB in 0s (0 B/s)
  Traceback (most recent call last):64... 7%
    File "./bin/cnf-extract.py", line 54, in <module>
      mirror_root, suite, component, arch)
    File "/srv/cnf-extractor/extractor/extractor.py", line 174, in 
command_not_found_extract
      debpath = pkg.candidate.fetch_binary(destdir=tmpdir)
    File "/usr/lib/python3/dist-packages/apt/package.py", line 883, in 
fetch_binary
      self.size, base, destfile=destfile)
  OverflowError: signed integer is greater than maximum

  I'll get more context for the Jammy failure but it wouldn't surprise
  me if it was the same package.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1998265/+subscriptions


-- 
Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to