** Tags removed: foundations-todo

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.

  Mantic/23.10: PXE boot tries to initialize DHCP before network link is

Status in initramfs-tools package in Ubuntu:
  Fix Released

Bug description:
  I'm not sure whether this is the correct package for this bug, please
  reassign if not.

  I'm booting the Ubuntu Mantic/23.10 desktop beta image via PXE in
  order to perform an unattended installation. The kernel command line
  looks like that:

  iso/casper/vmlinuz --- ip=dhcp netboot=nfs
  nfsroot= autoinstall ds=nocloud\;s=<removed>

  This has worked perfectly before. However, in 23.10, the kernel tries
  to intialize DHCP before a network link is up.

  I can see a few instances of messages like the following:
  dhcpcd-10.0.2 starting
  dev: loaded udev
  no interfaces have a carrier
  exiting due to oneshot
  dhcpcd exited

  Then, the kernel tries to mount NFS, even though neither an IP address nor 
even a link is available:
  connect: Network is unreachable
  NFS over TCP not available from

  This is repeated for a while. In between, a message tells that now the link 
is up:
  [    10.0002805] e1000e 0000:00:19.0 enp0s25: NIC Link is Up 1000 Mbps Full 
Duplex, Flow Control: Rx/Tx

  The NFS messages repeat for a while, until the system gives up and I'm
  dropped into a busybox prompt.

  Executing dhcpcd now correctly gets IP addresses, but I don't know how
  to continue the boot from there.

  The problem occurs on most physical machines that I tried, but not in

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to