same error when installing `zram-tools` under jammy 22.04.3 LTS

$ sudo eatmydata apt install zram-tools
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
The following NEW packages will be installed:
  bc zram-tools
0 upgraded, 2 newly installed, 0 to remove and 33 not upgraded.
Need to get 93.3 kB of archives.
After this operation, 249 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 jammy/main amd64 bc amd64 
1.07.1-3build1 [87.6 kB]
Get:2 jammy/universe amd64 zram-tools all [5,676 B]
Fetched 93.3 kB in 0s (522 kB/s)
Selecting previously unselected package bc.
(Reading database ... 48059 files and directories currently installed.)
Preparing to unpack .../bc_1.07.1-3build1_amd64.deb ...
Unpacking bc (1.07.1-3build1) ...
Selecting previously unselected package zram-tools.
Preparing to unpack .../zram-tools_0.3.3.1-1_all.deb ...
Unpacking zram-tools ( ...
Setting up bc (1.07.1-3build1) ...
Setting up zram-tools ( ...
Created symlink /etc/systemd/system/ → 
Could not execute systemctl:  at /usr/bin/deb-systemd-invoke line 142.
Processing triggers for man-db (2.10.2-1) ...
Processing triggers for doc-base (0.11.1) ...
Processing 1 added doc-base file...

this is line 142 in /usr/bin/deb-systemd-invoke

            system('systemctl', '--quiet', @instance_args, $action,
@start_units) == 0 or die("Could not execute systemctl: $!");

$ dpkg -S /usr/bin/deb-systemd-invoke
init-system-helpers: /usr/bin/deb-systemd-invoke

$ apt policy $(dpkg -S /usr/bin/deb-systemd-invoke|cut -d: -f1)
  Installed: 1.62
  Candidate: 1.62
  Version table:
 *** 1.62 500
        500 jammy/main amd64 Packages
        500 jammy/main i386 Packages
        100 /var/lib/dpkg/status

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to krb5 in Ubuntu.

  Cannot configure krb5-kdc on Ubuntu Jammy 22.04.01, "Could not execute
  systemctl:  at /usr/bin/deb-systemd-invoke line 142."

Status in init-system-helpers package in Ubuntu:
Status in krb5 package in Ubuntu:

Bug description:
  I have a fresh install of Ubuntu Server 22.04.01 LTS.  After
  installing the server and running all updates, I run the following

  apt -y install slapd ldap-utils schema2ldif sasl2-bin
  libsasl2-modules-gssapi-mit krb5-kdc-ldap krb5-admin-server krb5-kdc

  This will be installing krb5-kdc 1.19.2-2.

  This is in preparation for setting up an OpenLDAP server, a Kerberos
  server with an LDAP backend, and saslauthd for pass-through
  authentication.  krb5-kdc was auto-selected when running the steps in
  the guide here in my development environment:
  When installing that, I get the following in the output:

  Setting up krb5-kdc (1.19.2-2) ...
  Created symlink /etc/systemd/system/ 
→ /lib/systemd/system/krb5-kdc.service.
  Could not execute systemctl:  at /usr/bin/deb-systemd-invoke line 142.

  I do get the prompts for the realm, kdc, and admin server hostnames,
  and they are reflected in /etc/krb5.conf.  If I then run the

  dpkg-reconfigure krb5-kdc

  I am prompted for whether I want the package to create the Kerberos
  KDC configuration automatically, and when I say yes, it then repeats
  the following error:

  Could not execute systemctl:  at /usr/bin/deb-systemd-invoke line 142.

  I cannot find any further debug in the syslog or anything to indicate
  what the root cause is; the list of packages here are all installed
  together on a separate development server where I experimented with
  the configuration I will be deploying here in production so I don't
  think it's incompatible packages in the install list, but I am open to
  feedback on that.

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to