Do you generally recommend installing a version newer than the default of e.g. Trisquel Belenos, or is that not necessary?

Reply via email to