... Nope. My bad. I went back and did that, after which I was able to run

$ guix package -i hello

(side-note, how does one do code blocks in this forum?)

I now run

$ guix package -A lilypond*

and see Lilypond 2.19.58, which the current unstable version. The current stable version is 2.18.2. Lilypond alternates between stable and unstable releases, with unstable releases being given odd second version numbers (2.17*, 2.19*). Guix probably has no way of knowing this and doesn't recognize that 2.19.58 is not a stable release. Can Guix be used to access the "older" 2.18.2? Even if not, Guix seems awesome in general and solves some other unrelated problems for me.

Reply via email to