Hello,

today i got a problem doing an upgrade:

sudo apt-get dist-upgrade:
--------------------------

Ign http://es.archive.trisquel.info belenos-security/main Translation-de
Ign http://es.archive.trisquel.info belenos-updates/main Translation-en
Ign http://es.archive.trisquel.info belenos-updates/main Translation-de
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libruby1.9.1 : Depends: ruby1.9.1 (= 1.9.3.484-2ubuntu1.8) but 1.9.3.484-2ubuntu1.7 is installed ruby1.9.1 : Depends: libruby1.9.1 (= 1.9.3.484-2ubuntu1.7) but 1.9.3.484-2ubuntu1.8 is installed
E: Unmet dependencies. Try using -f.

sudo apt-get -f install:
------------------------

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  ruby1.9.1
Suggested packages:
  ruby1.9.1-examples ri1.9.1 graphviz ruby1.9.1-dev ruby-switch
The following packages will be upgraded:
  ruby1.9.1
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0 B/35.6 kB of archives.
After this operation, 1024 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 303199 files and directories currently installed.)
Preparing to unpack .../ruby1.9.1_1.9.3.484-2ubuntu1.8_amd64.deb ...
Unpacking ruby1.9.1 (1.9.3.484-2ubuntu1.8) over (1.9.3.484-2ubuntu1.7) ...
dpkg: error processing archive /var/cache/apt/archives/ruby1.9.1_1.9.3.484-2ubuntu1.8_amd64.deb (--unpack): unable to install new version of `/usr/bin/ruby1.9.1': Device or resource busy
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for menu (2.1.46ubuntu1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/ruby1.9.1_1.9.3.484-2ubuntu1.8_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

This is on Trisquel 7.

I do not know how i can solve this problem.

Can someone help me?

Thanks in advice!

Reply via email to