Youtube-dl is now working again. I didn't follow any of the newer instructions above. But if I remember rightly, I did upgrade to a newer version of the Linux kernel since I last tried. Maybe that helped somehow?

Centurino
> The situation wouldn't be much better on other fixed-release distros, even those that are currently up-to-date.

Doesn't that depend on the cause of the problem? Some of the comments here suggest that the problem is youtube-dl running with Python2, instead of Python3. Since the EoL was announced for Python2 some time ago, I presume distros maintainers would have ensured that they shipped Python3 in newer versions, and made it the default version that Python programs use.

> They will quickly fall behind in their versions of youtube-dl and incompatibilities between the script and site APIs will surface.

That's not been my experience with youtube-dl on Flidas. Apart from this recent hiccup, it has always worked fine on YT or Invidious instances, as mentioned in the OP. Perhaps the Trisquel devs backport the latest versions?

Reply via email to