Your network connection worked when you came to the Installfest.
Ian configured the kernel because I was busy doing other stuff. As I 
can imagine he used the old .config of the kernel? I think you should 
give it a shot and try the other 3com modules I remember seeing being 
in your module file:
$ cd /lib/modules/2.4.24/kernel/drivers/net
$ ls
//use filenames without extension (.o) as modprobe?s arguments
$ modprobe ExampleFilename3com
$ ping
//keep going if unsuccessful

Ian Monroe wrote:

>The 2.6 kernel has issues with the IBM 300GL and the 3com cards. You 
>have to do a cold boot or reboot from a 2.4 kernel (or any other OS 
>actually). I imagine this is what your probably doing anyways, since 
>obviously had to a cold boot when you returned. Running the command 
>`dmesg | less` will give you the kernel output, see if you see 
>about the ethernet card. You can do that after a insmod (I would 
>using the command modprobe instead) and see what new messages it puts 
>You can follow the kernel bug at:
> (it has the errors 
>messages you would see if you have the problem I described).
>Alex might have compiled it into the kernel so it doesn't need to be 
>loaded. Are you sure the ethernet is the problem? You could typing 
>dhclient as root and see if you pick up an internet address or not, 
>though I guess you'll be using a static ip (which requires using 
>Chad Mohler wrote:
>> Hi, all.
>>      At the InstallFest on Saturday, Alex (Alec?) and Ian were great 
>> helping me successfully upgrade to the Debian 2.4.25 kernel on the IBM 
>> 300GL machine (model#6285) that is to be the new server on campus for 
>> Moodle, the open-source alternative to Blackboard. Unfortunately, with 
>> the kernel upgrade, the Ethernet card (a 3com "Vortex" model) is no 
>> longer working on the machine (either booting up with the new kernel 
>> with the old one, 2.4.18, with which the Ethernet card had previously 
>> worked).  At the advice of Don Bindner, I added to the /etc/modutils 
>> directory a file called "local" with the single line in it, "alias 
>> 3c59x."  That didn't get the Ethernet card working (nor did adding 
>> line to the aliases file in the same directory).  Running "insmod 
>> 3c59x," I got the reply that the module already existed.
>>      Any help you could offer in getting the Ethernet card recognized 
>> would be great.  It's hard for the machine to be a server without an 
>> Internet connection!  Thanks.
>> --- Chad
>> P.S.:    I'd bring the machine to the Wednesday TSLUG meeting, but 
>> unfortunately, I have another commitment already scheduled for the 
>> time.
>To get off this list, send email to [EMAIL PROTECTED]
>with Subject: unsubscribe

To get off this list, send email to [EMAIL PROTECTED]
with Subject: unsubscribe

Reply via email to