Am 18.10.2016 um 06:29 schrieb Mingcai SHEN:
I tried both on linux and windows, and they are the same, not text
inside the tags was extracted into pot file. very strange....
Problem with virtualenv ?

It should work with virtualenv as well.
Here are the steps you should try:

Create and activate a virtual env, then:

pip install tg.devtools
gearbox quickstart -jnx example
cd example
pip install .

In example/templates/about.jinja,
under {% block contents %} add these lines:

{{ gettext('Hello gettext!') }}
{% trans %}Hello trans!{% endtrans %}

Then run:

python extract_messages

The output should now contain the line:
"extracting messages from example/templates/about.jinja"

The file example/i18n/example.pot should be created
and should contain these lines taken from about.jinja:

msgid "Hello gettext!"
msgid "Hello trans!"

-- Chris

在 2016年10月17日星期一 UTC+8下午9:39:07,Christoph Zwerschke写道:

    Am 17.10.2016 um 14:56 schrieb Mingcai SHEN:
    > But it just can extract {% trans %} {% endtrans %} or {{
    gettext('') }}
    > from the template files into the pot file.

    You meant *can't* extract, not *can* extract, right?

    I just tried it with a newly created project, and this simple template:

    {{ gettext('Hello gettext!') }}
    {% trans %}Hello trans!{% endtrans %}

    Both texts were copied to the i18n/*.pot file.

    I have used Python 2.7, TG 2.3.9, Babel 2.3.4 and Jinja2 2.8.

    Are you using any different versions? Also, does it work for you with a
    newly created project and the above simple template?

    -- Chris

You received this message because you are subscribed to the Google Groups 
"TurboGears Trunk" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
To post to this group, send email to
Visit this group at
For more options, visit

Reply via email to