On Mar 7, 2007, at 6:42 PM, Jim Marino wrote:

When we convert over to the federated marhsallers, I think we can get rid of AtomicComponent and just have Component. To do this, we would need to move some of the lifecycle getters such as conversational lifetime, etc. to Component. The other change we would need to do is have InstanceWrapper handle init() and destroy () callbacks. I think we can do this by having the wrapper generated on the controller and serialized across. This would allow us to eliminate reflection. Finally, JavaTargetInvoker (should be renamed) would then deal with InstanceWrappers which it obtained from the ScopeContainer, as opposed to AtomicComponent.

What do people think?

I started down that route a while ago refactoring InstanceWrapperImpl to be one specialization of InstanceWrapperBase that used the current mechanism of delegating back to the component (at least until we could clean that up).

Have a look at PhysicalComponentTestCase for an example of what a generated alternative would look like.
--
Jeremy


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to