Hi,

Thank you for looking into this. It's a feature instead of a bug :-).

The code in org.apache.tuscany.sca.interfacedef.wsdl.impl.WSDLOperationIntrospectorImpl.Wrapper.getInputChildElements() is to check if the WSDL operation is document-literal-wrapper style per JAX-WS spec (section 2.3.1.2). If the operation name doesn't match the wrapper element name, then it is not a wrapper style and we don't care about child elements in this case.

You are welcome to report any suspicions if you run into any issues with your WSDL.

Thanks,
Raymond
--------------------------------------------------
From: "Wang Feng" <[EMAIL PROTECTED]>
Sent: Tuesday, April 01, 2008 7:14 PM
To: "tuscany-dev" <tuscany-dev@ws.apache.org>
Subject: Parsing the wsdl file,is part element name must equals operation's name?

Hi,all

When Parsing the wsdl file,there is a constraint that the element name of the part on the operation input messge must equals the operation's name. I don't find the constraint on the wsdl spec,so I think the constraint should be removed.

The snippet :
Part part = (Part)parts.iterator().next();
QName elementName = part.getElementName();
if (elementName == null) {
   return null;
}
if (!operation.getName().equals(elementName.getLocalPart())) {
   return null;
}

If this is a bug,I will put a jira.

--------------
Wang Feng
2008-04-02


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to