+1 - I am experiencing the same problem.

I'm running Twitter API requests as part of a unit test for my code
(HTTPBuilder- http://groovy.codehaus.org/modules/http-builder/).  This
has always worked fine up until a couple weeks ago.  Looks like there
is a bug report here:
http://code.google.com/p/twitter-api/issues/detail?id=949

It might have something to do with the time between when the tweet is
posted and deleted -- at least in my case, my unit test creates the
tweet and deletes it just a second or two later.  It could have to do
with cluster propagation -- i.e. the original post hasn't been
propagated to the node which is handling the 'delete.'  I'm just
speculating of course, but before this error cropped up, I was seeing
a different behavior where sometimes the delete request would return
successfully, but my tweet would remain visible.  This is probably a
similar root cause, except the delete occurs while the post is still
propagating, and makes it to a cluster node after the delete
propagates or something.  I tried putting a delay of ~10s between the
post and delete, and it did not seem to help...

On Aug 19, 9:18 am, srikanth reddy <srikanth.yara...@gmail.com> wrote:
> yes i too encountered this (both status/destroy and direct_messages/destroy
> are giving 400 error but the status gets deleted successfully. The response
> text says something like "somehow we could not delete this tweet."
>
> On Wed, Aug 19, 2009 at 3:38 PM, deepikagupta <deepikaggu...@gmail.com>wrote:
>
>
>
> > Hi,
>
> > I am facing an issue with statuses/destroy API call. It returns 400
> > (bad request) even though mentioned tweet id is delered sucessfully.
>
> > The method was working fine few days back but started gicing trouble
> > recently.
>
> > Anyone having same trouble? Is anything wrong with this API call?

Reply via email to