There's a note on the Status blog that we're having some delays in
processing a proportion of new statuses. This issue looks to largely
be resolved, and all the subsequent backlogs have been processed --
except there's still a bit of a backlog pushing statuses to Facebook
that should resolve soon enough.

I'd imagine that your test status was delayed. Then, when you tried to
delete it, it wasn't available. You should try again now. The queues
look to be empty.

-John


On Sep 2, 9:38 am, "Ted Neward" <ted.new...@gmail.com> wrote:
> I've been hacking on the Twitter API, and I'm running into some serious
> weirdness with destroy.
>
> I post a message:
>
> C:\> curl -u name:pass -d 
> "status=Testing"http://twitter.com/statuses/update.xml
>
> <?xml version="1.0" encoding="UTF-8"?>
>
> <status>
>
>   <created_at>Wed Sep 02 10:10:23 +0000 2009</created_at>
>
>   <id>3708721364</id>
>
>   <text>Testing</text>
>
>   <source>&lt;a href=&quot;http://apiwiki.twitter.com/";
> rel=&quot;nofollow&quot;&gt;API&lt;/a&gt;</source>
>
>   <truncated>false</truncated>
>
>   <in_reply_to_status_id></in_reply_to_status_id>
>
>   <in_reply_to_user_id></in_reply_to_user_id>
>
>   <favorited>false</favorited>
>
>   <in_reply_to_screen_name></in_reply_to_screen_name>
>
>   <user>
>
>     <id>70927096</id>
>
>     <name>Ted Neward</name>
>
>     <screen_name>TestingScitter</screen_name>
>
>     <location></location>
>
>     <description></description>
>
> <profile_image_url>http://s.twimg.com/a/1251845223/images/default_profile_no
> rmal.png</profile_image_url>
>
>     <url></url>
>
>     <protected>false</protected>
>
>     <followers_count>1</followers_count>
>
>     <profile_background_color>9ae4e8</profile_background_color>
>
>     <profile_text_color>000000</profile_text_color>
>
>     <profile_link_color>0000ff</profile_link_color>
>
>     <profile_sidebar_fill_color>e0ff92</profile_sidebar_fill_color>
>
>     <profile_sidebar_border_color>87bc44</profile_sidebar_border_color>
>
>     <friends_count>6</friends_count>
>
>     <created_at>Wed Sep 02 09:49:13 +0000 2009</created_at>
>
>     <favourites_count>0</favourites_count>
>
>     <utc_offset></utc_offset>
>
>     <time_zone></time_zone>
>
> <profile_background_image_url>http://s.twimg.com/a/1251845223/images/themes/
> theme1/bg.gif</profile_background_image_url>
>
>     <profile_background_tile>false</profile_background_tile>
>
>     <statuses_count>4</statuses_count>
>
>     <notifications>false</notifications>
>
>     <verified>false</verified>
>
>     <following>false</following>
>
>   </user>
>
> </status>
>
> . which is all good, but then I try to delete that message:
>
> C:\ >curl -u name:pass --http-request 
> DELETEhttp://twitter.com/statuses/destroy/3708721364.xml
>
> <?xml version="1.0" encoding="UTF-8"?>
>
> <hash>
>
>   <request>/statuses/destroy/3708721364.xml</request>
>
>   <error>We could not delete that status for some reason.</error>
>
> </hash>
>
> What gives? Is this something that I'm doing wrong on my end? Momentary
> server weirdness? (Though it seems to have been pretty consistent all
> night.)
>
> Ted Neward
>
> Java, .NET, XML Services
>
> Consulting, Teaching, Speaking, Writing
>
>  <http://www.tedneward.com>http://www.tedneward.com

Reply via email to