Hello Damon!

I'm not 100% sure I buy this explanation:

1. This problem wasn't happening a day or two ago.

2. I tried executing the query on the command line, and incremented
the since_id by 1 maybe 8-10x ... it just doesn't return any results.

Even weirder is that if I wait 20 minutes, and execute the same query
with the same original since_id, then I might get some of the results,
but not all of them.

Currently, the only solution I can see is to simply never use since_id
and just filter out - on the client - those tweetids I've seen
already.  Seems like a horrible waste of bandwidth and computing
power, and especially strange given that this largely worked a few
days ago, right before some other changes were rolled out that also
seemed to cause a sudden increase in 500-series errors being returned
from the servers and other weirdnesses.


Thanks,
Marc.


On Oct 23, 9:31 pm, Damon Clinkscales <sca...@pobox.com> wrote:
> Christopher
>
> To my recollection, for search with since_id to work properly, the
> tweet id must be in the search index.  In this case:
>
> http://search.twitter.com/search?q=+from%3Asilent_tester02
>
> does not yield the "Dinner, movie, drinks." tweet in the index.
>
> As an aside, I did an "exact match search" on that phrase above and it
> returned many results that are not exact matches. But that's a
> separate issue.
>
> You could file an issue about the fact that the results coming back
> are not always consistent, but the first thing I would do is make sure
> that I am using a since_id that actually exists in the search index.
> Granted this can be a bit of a pain to verify this 100% of the time
> because sometimes tweets do not end up in the search index (which
> appears to be the case here). But in my experience, most of the time,
> they do.  So as a test, pick a tweet you know is in the index and make
> some calls with it over a period of time.  See if the results are
> consistent.
>
> Best,
> -damon
> --http://twitter.com/damon
>
> On Tue, Oct 20, 2009 at 9:06 AM, Christopher Warren
>
>
>
> <christopher.war...@gmail.com> wrote:
>
> > We have an app that runs searches regularly, and recently stopped
> > receiving new tweets. After investigating we found a search
> > combination that seems to break the search API. Instead of getting a
> > response with no tweets, an .atom request errors and a .json request
> > 404s.
>
> >http://search.twitter.com/search.json?q=from:silent_tester02&since_id...
> >http://search.twitter.com/search.atom?q=from:silent_tester02&since_id...
>
> > Changing the query to not use from:username works as expect, but I've
> > put several usernames in and they all respond the same way. I haven't
> > managed to narrow down the cause of the problem much further than
> > that, but we're handling it in our code by rescuing any failed
> > searches and appending since: with the date of the most recent tweet
> > to the q.
>
> > Any thoughts on what might be causing this would be appreciated.

Reply via email to