I having this error for a while and is happening only on my machine, I
deploy the same project in another similar VM and it worked, so I am
starting to think that there might be something related to my
environment that is causing the 401 Unauthorized issue. I have a Mac
with OS 10.5.6 and a VM running on Paralles, the VM is Fedora Core
running ruby 1.8.6 (2007-06-07 patchlevel 36) [i386-linux], i am using
twitter (0.7.5) and oauth (0.3.6) and when I run this code:

oauth = Twitter::OAuth.new('consumer_key', 'consumer_secret')
atokens = oauth.request_token(:oauth_callback => callback)

I always get a 401 Unauthorized, apparently a couples of weeks ago
there was a general issue with twitter API and was getting the same
from a completely different environment (PC) but now the general issue
seems to be solved my PC is able to run the code but my VM still
giving me the 401, any clue on how could I do further tests?

BTW: I have already ask on the Twitter gem Google Group, waiting for
answer. Just wanted to see if you could give me a clue


Reply via email to