Just had the same issue when working on my Tweet Blender plugin and
found out that the example given by twitteroauth author had method and
parameters swapped.

The function takes 3 arguments: url, method, and params. Author's
example had method as the 3rd argument but it should be the 2nd.  My
call that had the same error looked like this:

$jsonData = $oAuth->OAuthRequest('https://twitter.com/statuses/
user_timeline.json', array('screen_name' => $_GET['screen_name']),
'GET');

The correct code that worked is

$jsonData = $oAuth->OAuthRequest('https://twitter.com/statuses/
user_timeline.json', 'GET', array('screen_name' => $_GET
['screen_name']));

Hope that helps.

Kirill

On Nov 17, 9:21 am, Venkatesh <venki.onm...@gmail.com> wrote:
> Hi All,
>
>    Am new to twitter and wants to create an application in twitter for
> sharing information from my site.
>    For this I have downloaded an PHP library for working with
> Twitter's OAuth API from the below link
>
>    http://github.com/abraham/twitteroauth
>
>    with the help specified in the 
> linkhttps://docs.google.com/View?docID=dcf2dzzs_2339fzbfsf4
>
>    To achieve Twitter's OAuth I followed the exact steps which are
> specified inhttps://docs.google.com/View?docID=dcf2dzzs_2339fzbfsf4
>
>    but I'm getting error as shown below
>
>     Fatal error: Cannot unset string offsets in D:\xampp\htdocs\civio
> \twitter\twitteroauth2.0\twitteroauth\twitteroauth.php on line 145
>
>     I commented the line where I got the above line and I still get
> the error
>     Warning: array_merge() [function.array-merge]: Argument #2 is not
> an array in D:\xampp\htdocs\civio\twitter\twitteroauth2.0\twitteroauth
> \OAuth.php on line 249
>     and nothing is happing after this.
>
>    Am total stuck here. Please help me in resolving this issue.
>
> Thanks in advance,
> Venkatesh M.

Reply via email to