I'm trying to retrieve a tweet via 
(also tried http://twitter.com/statuses/show/<id>.xml, but same
results) on my own *protected* account and passing in my own network
credentials. But I'm getting a 403 Forbidden. If I unprotect my
tweets, it works just fine. I *can*, however, update my status while
protected (passing in credentials by same method).

Anybody else experiencing this? I'm sure this worked a couple weeks
ago, but now it doesn't. ???

I'm using the .Net framework. Here's my code if anyone's curious:

public static void GetTweet(string tweetId)
string twitterUrl = string.Format("http://twitter.com/statuses/show/
{0}.xml", tweetId);
HttpWebRequest request = (HttpWebRequest)HttpWebRequest.Create
request.ContentType = "application/x-www-form-urlencoded";
request.Method = "GET";
request.Credentials = new NetworkCredential(TwitterUserName,
request.Timeout = 60000;
request.UserAgent = ".NET Framework Test Client";
WebResponse response = request.GetResponse(); // -- WebException
thrown here --

Reply via email to