it's clearly a bug.

the status update method returns (on success) the newly created
status. I rely on this status for the application state.
what our servers get when updating with "RT..." are older unrelated
tweets (days ago) and the statuses never gets published on twitter.

I tried updating a little from the web. what goes on there is totally
voodoo. I get different error messages.
try updating this "RT... hello" you'll probably get a "hello hasn't
published any tweets yet"
I tried random messages like "RT... rth984th34" and it made me retweet
some guy I don't even know.

I don't know if the system treats it like SMS or not. doesn't matter.
it's a bug.
I shouldn't be getting unrelated tweets as a response to a status
update no matter what.
I shouldn't be retweeting people I don't know on sending malformed
status updates.



On Dec 8, 8:34 pm, Raffi Krikorian <ra...@twitter.com> wrote:
> i think that's precisely it.  the twitter API follows (mostly) the
> same commands that are available over SMS.  if you send a tweet that
> starts with "RT", then the API will assume you are attempting to do a
> native RT.
>
> On Tue, Dec 8, 2009 at 10:28 AM, Cameron Kaiser <spec...@floodgap.com> wrote:
> >> I just came across a weird bug.
> >> When updating statuses with the text "RT..." included, unexpected
> >> things happen.
>
> > If it's first position in a line, it's probably being seen as an SMS
> > command (there is an RT SMS command).
>
> > --
> > ------------------------------------ 
> > personal:http://www.cameronkaiser.com/--
> >  Cameron Kaiser * Floodgap Systems *www.floodgap.com* ckai...@floodgap.com
> > -- Another visitor. Stay awhile. Stay forever! -- Professor Elvin 
> > Atombender --
>
> --
> Raffi Krikorian
> Twitter Platform Teamhttp://twitter.com/raffi

Reply via email to