hi!

hmm - you may be tripping over a known issue where we don't update the
"status objects" coming from the api correctly.  if you do a users/show call
and look at your account, did that get updated after you upload?

just to give some background - we embed the user object inside the status
object in the API (if you call any one of the timelines and get an array of
status objects back, you'll notice that each has the full details of the
user inside).  its actually an expensive-ish operation for us to invalidate
all those objects in your entire timeline when you change something in your
user object.  we're currently still working out ways around that issue.


On Wed, Feb 3, 2010 at 1:51 PM, whomba <andrew.l...@gmail.com> wrote:

> Hello all
>
> I've been using twitter functionality in my sites for a while now and
> wanted to expand to uploading images to the users Background.  After
> following the oauth Spec for twitter  background I was able to
> successfully upload an image.  Unfortuneatly,  this does not always
> work.  Lately, more and more  calls up to twitter are returning false
> positives.  Meaning that I make the request, and according to twitter
> it executes successfully, however my BG Image does not change.
>
> My response is as follows:
>
> {"verified":false,"followers_count":
> 8,"url":null,"description":null,"profile_text_color":"0C3E53","status":
>
> {"in_reply_to_screen_name":null,"favorited":false,"in_reply_to_status_id":null,"truncated":false,"created_at":"Wed
> Feb 03 21:29:02 +0000 2010","source":"<a href=\"http://www.webfetti.com
> \" rel=\"nofollow\">Webfetti</a>","in_reply_to_user_id":null,"id":
> 8603955578,"text":"I just updated my twitter background using Webfetti
> Check it out!
> http://bit.ly/9joxaG"},"profile_background_image_url":";
> http://a1.twimg.com/profile_background_images/72229696/image
> ","created_at":"Tue
> Oct 20 21:55:54 +0000
> 2009","profile_link_color":"FF0000","statuses_count":
>
> 76,"profile_background_tile":false,"notifications":false,"profile_background_color":"BADFCD","profile_image_url":"http://
> a3.twimg.com/profile_images/673971289/
> image_normal","contributors_enabled":false,"favourites_count":
> 1,"lang":"en","time_zone":null,"friends_count":
>
> 7,"profile_sidebar_fill_color":"FFF7CC","protected":false,"screen_name":"whombaWork","following":false,"location":null,"name":"andrew","geo_enabled":false,"profile_sidebar_border_color":"F2E195","id":
> 83934696,"utc_offset":null}
>
> So the problem is that According to twitter, everything went
> perfectly, however according to my actual twitter profile, nothing
> worked as it should have.  Also, if you look at my
> 'profile_background_image_url' this shows my OLD background image, not
> my new one.
>
> I use exactly the same code to update my profile picture and it works
> every time.  The BG image size is within the size requirement and
> dimensions.
>
> Any help would be awesome.  Thank you in advanced
>
>


-- 
Raffi Krikorian
Twitter Platform Team
http://twitter.com/raffi

Reply via email to