After chatting with one of the engineers at TwitPic they appear to
have fixed the invalid oauth header issue, now I get a 401 error
saying my API key is invalid even though it's a copy and paste from
their site

On May 16, 3:18 pm, Rich <rhyl...@gmail.com> wrote:
> I've spent a good 12 hours on this so far and this is where I've got
> to
>
> 1) I use the same code to generate the oAuth header for echo and
> communicating to the Twitter API
> 2) I generate a fake request to verify_credentials and generate the
> oauth http header but change Authorization to X-Verify-Credentials-
> Authorization and add the X-Auth-Service-Provider header
> 3) I change the request url to the TwitPic api and post the image
> 4) TwitPic comes back with a 401 oauth header error (specifically says
> oauth header in the response)
>
> To check the oAuth header was OK I change my code to use Authorization
> instead of X-Verify-Credentials-Authorization and send it directly to
> verify_credentials (obviously ignoring the image data part!)
>
> Twitter responds with JSON and an HTTP status of 200, so I'm pretty
> sure that my oAuth header is right
>
> On May 16, 12:36 am, gotosleep <gotosl...@gmail.com> wrote:
>
>
>
> > I am having the exact same issue with Twitpic. I use the same code to
> > generate the OAuth header for Twitpic as I do for Twitter, but Twitpic
> > always returns a 401.
>
> > On May 15, 6:26 pm, Rich <rhyl...@gmail.com> wrote:
>
> > > To follow up, if I simply actually call verify_credentials it returns
> > > a valid json object for my request but returns a status code of 401
>
> > > On May 16, 12:01 am, Rich <rhyl...@gmail.com> wrote:
>
> > > > Has anyone else had problems with oAuth echo and services like TwitPic
>
> > > > I'm using the SAME objective-c library to generate the oAuth signature
> > > > as for the client (which by the way the client works fine so the oAuth
> > > > signatures for that are fine).
>
> > > > I'm generating the oAuth headers as if it were 
> > > > forhttps://api.twitter.com/1/account/verify_credentials.jsonandaddit
> > > > to the http headers as per Raffi's documenation.
>
> > > > When I look at the oAuth headers they look fine, but TwitPic
> > > > constantly returns a 401

Reply via email to