Hi

I finally found the solution. In fact de "%3D" was really missing at the end of 
my signature. I had to ad it as a pad in my HMAC-SHA1javascript lib encoder.
Now it works.

Hope this self solved can help

Michel Perrin
Le 22 mai 2010 à 09:48, Michel Perrin a écrit :

> I'm trying for many days to make it work  for an iPhone App that I'm 
> developing with Titanium Appcelerator.
> I'm getting a a 401 error at every attempt. I'm basically using a HMAC-SHA1 
> js library that might be faulty. I checked in many samples on this list that 
> most of the signatures are ending by "%3D" and mine is never ending by those 
> characters.
> 
> Here's one of my signature base string and header assuming that XXXX and 
> XX________XX are masqued values for the purpose of this post
> 
> signature base string :
> 
> POST&https%3A%2F%2Fapi.twitter.com%2Foauth%2Faccess_token&oauth_consumer_key%3XX________XX%26oauth_nonce%3D1274444947%26oauth_signature_method%3DHMAC-SHA1%26oauth_timestamp%3D1274444946%26oauth_version%3D1.0%26x_auth_mode%3Dclient_auth%26x_auth_password%3DXXXX%26x_auth_username%3DXXXX
> 
> headers :
> 
> 'POST','https://api.twitter.com/oauth/access_token'
>               
> 'Content-Type', 'application/x-www-form-urlencoded'
> 'Authorization', 
> 
> OAuth oauth_nonce="1274438928", oauth_signature_method="HMAC-SHA1", 
> oauth_timestamp="1274438926", oauth_consumer_key="XX________XX", 
> oauth_signature="pfACjg1vlhpuIa9esoL4v14ATOQ", oauth_version="1.0"
> Data : x_auth_username=XXXX&x_auth_password=XXXX&x_auth_mode=client_auth
> 
> Any help much apreciated
> 
> Michel Perrin

Reply via email to