Are the scripts on the same server? Same version of PHP? Are they using the
same accounts access tokens? Same consumer token?


On Sun, May 23, 2010 at 18:07, Jonathan <> wrote:

> I've been trying to get my application to work with TwitterOAuth for
> several weeks now. Here’s a brief history:
> I need to authorize user requests of three different types. For that
> purpose I’ve got two scripts (I’ll call them #1 and #2), and #2 is
> invoked in two places.
> Several weeks ago I got script #1 to work with an old version of
> TwitterOAuth, which did not support specifying a callback URL for each
> call. I then tried to migrate to a newer version (beta-0.2.0), which
> would support specifying a callback URL, and script #1 ceased to work.
> Everything seemed OK up to the point where I tested the access token
> by performing a verify_credentials operation; then I got back an error
> that said “could not authenticate you.”
> I had no luck identifying the problem, so today I fell back to the old
> version of TwitterOAuth. Now script #1 works again, but script #2 does
> not. It returns the same error, “could not authenticate you.”
> I've inserted echo statements in both scripts to show the parameters
> and result of every call to TwitterOAuth. The sequences of calls are
> identical, and as far as I can tell the parameters and results are
> identical in every respect that they should be. Yet one call succeeds
> and the other fails.
> I've been beating may head against this thing for weeks, and I'm
> stumped.
> I'm open to any sort of advice on what the problem might be, or how to
> identify it, or how to work around it without identifying it.

Abraham Williams | Developer for hire |
@abraham | |
This email is: [ ] shareable [x] ask first [ ] private.

Reply via email to