One of the users of my app has complained that he can see his tweets in my
app but cannot post the tweets. The tweets are shown blank and the source as
'via API'  in the web. He confirmed that they were not posted from any Basic
Auth app (he changed his password and tried my app)and his connections
(settings->connection from web) shows my app as the only app he has
authorized and it has 'read only access ' .
 I checked this with a different account which had earlier granted 'read and
write' access to my app . i revoked the access and tried to use my oAuth
app. Surprisingly twitter oauth login page displayed my app asking for read
access  (not 'read and update'). I then verified my app's settings in
dev.twitter.console and surprised to see that 'read only' option is set. I
Changed this to 'read and write' and after that it seemed to work correctly.
I have two questions
1) why was my app's setting changed to 'read only'
2) Is it possible (by mistake) that the source parameter for an oAuth app
change to' viaAPI' ?

Thanks in advance

Reply via email to