I got an error 500 after I get the authentication (from
https://api.twitter.com/oauth/access_token). I get this error while
trying to contact https://api.twitter.com/1/statuses/home_timeline.json.

I'm using xAuth and
- I'm using SSL
- I'm using the header-based OAuth (which is OAuth
oauth_consumer_key="ntPtgtvCM9uhnztNRoRQ",
oauth_signature_method="HMAC-SHA1", oauth_token="138545742-
B0ZpXKHP9BSoNGbf9V5i57wlGTeZcJUECK5s0pY7", oauth_version="1.0",
oauth_timestamp="1276386309", oauth_nonce="IbVN4h",
oauth_signature="Wb2OzXubbKxqz3yYpEqOxwVAiog=")
- My xAuth params are properly part of the signature base string (in
fact I think the authentication is not the culprit, since I get back
the oauth_token and the oauth_token secret)

I tried to specify include_entities either true or false, but the
result won't change.
I tried to fiddle around with the authentication header, but any
attempt to change the escaping or the encoding will result in a
"Authorization needed" message, therefore I assume the header is
properly encoded for either the access_token and the
home_timeline.json requests.

Is there anything else I can check or is there any actual server error
that prevents the request from being made?

Reply via email to