On Wed, Jun 23, 2010 at 7:01 PM, Matt Harris <thematthar...@twitter.com> wrote:
> If you don't have sudo rights on the machine you want to run twurl on you 
> will need to tell your system to install gems into your user folder. For most 
> cases this happens automatically when you leave sudo off of the call. One 
> method i've heard works is to change your GEM_HOME folder to somewhere you 
> have write access to. You can do this by typing something similar to:
>
>  export GEM_HOME=/home/myname/gems

OK, that worked for this line:

$ export GEM_HOME=$HOME
$ gem i twurl --source http://rubygems.org
Successfully installed twurl-0.6.1
1 gem installed
Installing ri documentation for twurl-0.6.1...
Installing RDoc documentation for twurl-0.6.1...


$ rake dist:gem
(in /home/twitreport/twurl)
rake aborted!
uninitialized constant Twurl::AbstractCommandController
/home/twitreport/twurl/Rakefile:6
(See full trace by running task with --trace)

And now I'm stuck again. I tried googling and guessing, but neither of
them worked :-/

TjL

Reply via email to