Hullo Matt,
 Thanks for the reply...
I'm too far down this road to take detours...I've got everything
working except the final step...everything else checks in well..
I'm just hung up on the objhttp load using vba, somehow the stream
loaded seems to fail the generated signature (signature has been
checked)...so just need to figure this...hopefully something good will
happen before Aug 16.

Thanks,
Regards,
Shob

On Jul 7, 8:07 am, Matt Harris <thematthar...@twitter.com> wrote:
> Hi Shob,
>
> We strongly recommend you use a library for handling OAuth with Twitter
> until you are comfortable with how OAuth works. For VB I know of at least
> one library called TwitterVB:http://twittervb.codeplex.com/
>
> This will do the OAuth heavy lifting for you so you can develop an
> application for use with Twitter quickly. If you then want to roll your own
> solution you could use the TwitterVB library to compare to the results you
> are getting from your function.
>
> Hope that helps,
> Matt
>
>
>
> On Tue, Jul 6, 2010 at 7:10 AM, Jacky <jaga...@gmail.com> wrote:
>
> > Hullo,
>
> > POST&https%3A%2F%2Fapi.twitter.com%2Foauth
> > %2Frequest_token&oauth_callback%3Doob%26oauth_consumer_key
> > %3DhUMUUZO3Zx9zNzJ9DghcA%26oauth_nonce
> > %3DDA39A3EE5E6B4B0D3255BFEF95601890AFD80709%26oauth_signature_method
> > %3DHMAC-SHA1%26oauth_timestamp%3D1277424969%26oauth_version%3D1.0
>
> > and
>
> > Oauth oauth_callback="oob",
> > oauth_consumer_key="hUMUUZO3Zx9zNzJ9DghcA",
> > oauth_nonce="DA39A3EE5E6B4B0D3255BFEF95601890AFD80709",
> > oauth_signature_method="HMAC-SHA1", oauth_timestamp="1277424969",
> > oauth_version="1.0", oauth_signature="%2Ff8P1dS6QVQnYCIc10kD1%2Bm2DkI
> > %3D"
>
> > using
>
> >  objhttp.Open "POST", "https://api.twitter.com/oauth/request_token";,
> > False
>
> >  objhttp.setRequestHeader "Content-type", "application/x-www-form-
> > urlencoded"
> >      objhttp.setRequestHeader "Authorization", strsend
> > objhttp.send("")
>
> > Not working, how can I see the stream that is being loaded...or debug
> > this...
> > and strsend is "Oauth " and appended by the very first string up on
> > top in this email
>
> > Cant see the problem...
>
> > Please help, if you can see anything outright off or wrong...
>
> > Regards,
> > Shob
>
> --
>
> Matt Harris
> Developer Advocate, Twitterhttp://twitter.com/themattharris

Reply via email to