Hello everybody,

Yesterday I was exposing an issue I encoutered.
My code was working perfectly, and then I started having a 401 error
code with this error message : "<error>Invalid / used nonce</error>"
when I make API calls.

I thought it was solved because yesterday I did some API calls that
made it through. However this issue is still here today.

Actually, when I make API calls (POST, GET or OAuth requests),
sometimes everything works fine, sometimes i have the "Invalid / used
nonce" error.

As I told Taylor yesterday, I am sure that that the system time is
correct (because when I change it, nothing works), and because as I
said, when i try to send a request with the exact same code running,
sometimes it fails, sometimes it does not.

Here are dumps of the communications

I tried to send a tweet, had an error : http://pastebin.com/ur2JYtnM

A few seconds later, i run the exact same code and it is valid :

(I will reset my key and secret ^^)

I really do not know where the issue comes from, because the code was
running flawlessly last week!

Any kind of help appreciated.


Mounir Regragui

Reply via email to