I have three iPhone apps that use OAuth to communicate with Twitter.
They have been working well for several months but recently when
trying to set-up authentication and exchange the various OAuth tokens
using Safari on the iPhone, Safari brings up a page from Twitter that
says:

Something is technically wrong.
Thanks for noticing -- we're going to fix it up and have things back
to normal soon.

Normally authentication works and the page Twitter returns redirects
back to our application on the iPhone.  Again, this has all worked for
several months until very recently.  We just noticed the problem
ourselves today.  Here's an example authenticate URL that used to work
but now fails:

http://twitter.com/oauth/authenticate?oauth_token=r8ZW21dPbUteSOgfFJ0AZnHkIwg1GfvRn9HaNMB7q0&force_login=true

Does anyone out there know what's going wrong?  This has all worked
for hundreds of thousands of our customers for several months now and
nothing in our app has changed in two months.  Can anyone shed light
on this for me?  Thanks!

-- 
Twitter developer documentation and resources: http://dev.twitter.com/doc
API updates via Twitter: http://twitter.com/twitterapi
Issues/Enhancements Tracker: http://code.google.com/p/twitter-api/issues/list
Change your membership to this group: 
http://groups.google.com/group/twitter-development-talk?hl=en

Reply via email to