Depending on what version of the library you're using it may default
to asynchronous mode.

try print_r($mentions->response);

On Aug 30, 8:44 pm, mirza <mirza.ganba...@gmail.com> wrote:
> hello my name is mirza.
>
> im new in develop twitter application. i think i have same problem.
> i want to get user mentions using get_statusesMentions().  i use
> epitwitter library.
> but the status result is empty. i dont know why. here is my code.
>
> $this->epiTwitter = new EpiTwitter($consumer->key,$consumer->secret,
> $user->reg_token,$user->access_token);
> $mentions = $this->epiTwitter->get_statusesMentions(array('max_id' =>
> $user->last_status_id));
> print_r($mentions);
>
> thanks
>
> best regards,
>
> mirza
>
> On Jul 22, 7:00 am, Mark Krieger <markskrie...@gmail.com> wrote:
>
> > Matt,
>
> > Thanks for the quick response. The call uses EpiTwitter.php, it looks
> > like:
>
> > Call Oauth to authenticate (this works), then:
>
> > $val = $twitterObj->get_statusesMentions(array('since_id' =>
> > $lastid));
> > $arr = json_decode($val->responseText, true);
> > if (empty($arr)) { $error = "error text"; log_message(...)}
> > else ...
>
> > It logs the "error text" showing the response through EpiTwitter was
> > empty. Also, when I print $val->responseText, it is EMPTY.
>
> > I've tried it on 4 twitter accounts I have, all of which have worked
> > for many months in code which has not changed, it has only failed
> > before when the api was down (like tuesday). And all other api calls
> > which use similar code all work fine. I am stumped.
>
> > I can send more data, like the $lastid, and my credentials for oauth
> > to you, I would of course do that privately. I will run some more
> > tests from here first I guess.
>
> > Thanks,
>
> > Mark
> > On Jul 21, 4:49 pm, Matt Harris <thematthar...@twitter.com> wrote:
>
> > > Hi Mark,
>
> > > We aren't seeing any errors like this when we run some tests. Could you
> > > elaborate on what the bogus headers are?
>
> > > Matt
>
> > > On Wed, Jul 21, 2010 at 12:51 PM, Mark Krieger 
> > > <markskrie...@gmail.com>wrote:
>
> > > > My application has used getStatusesMentions for many months, it is
> > > > only failing when twitter has had some problem, like two days ago, and
> > > > in that case, everything is flaky. Today it is failing, but everything
> > > > else works fine. Is this a known problem today? getStatusesMentions
> > > > always comes back today with bogus headers....
>
> > > > Mark
>
> > > --
>
> > > Matt Harris
> > > Developer Advocate, Twitterhttp://twitter.com/themattharris
>
>

-- 
Twitter developer documentation and resources: http://dev.twitter.com/doc
API updates via Twitter: http://twitter.com/twitterapi
Issues/Enhancements Tracker: http://code.google.com/p/twitter-api/issues/list
Change your membership to this group: 
http://groups.google.com/group/twitter-development-talk?hl=en

Reply via email to