Again: that's no xAuth, that's OAuth.

The issue here: there's no oauth_token present.

Tom


On 9/21/10 3:11 PM, andy wrote:
> Hello I have problems to send a new Direct Message.
> 
> I use xAuth to authentification to Twitter. I get an successful
> response with oauth_token and oauth_token_secret.
> 
> After this I send a request to get the friends Timeline. This I get
> returned, as I with a new basestring and a new key (consumer Secret +
> & + token_secret) forms.
> 
> Now I want to send a new DirectMessage with POST-parameters.
> 
> My base string is the following:
> POST&http%3A%2F%2Fapi.twitter.com%2F1%2Fdirect_messages
> %2Fnew.xml&oauth_consumer_key%3D..........%26oauth_nonce
> %3D0BAEA1F7-4A0B-ABB6-AA05-345F13153349%26oauth_signature_method
> %3DHMAC-SHA1%26oauth_timestamp%3D1285073867%26oauth_version
> %3D1.0%26screen_name%3Dname%26text%3DUpdatemyTwitter%26user_id
> %3D........
> 
> my signing Key is this:
> 
> myConsumerSecret&myTokenSecret
> 
> I send an Request on following URL:
> http://api.twitter.com/1/direct_messages/new.xml
> 
> my POST-parameter for the Request are ths:
> oauth_consumer_key=..............&oauth_nonce=2C5E2CF5-0AF9-7BD0-
> C28F-34638C796700&oauth_signature=KIio37Y
> +MTF4DIFBERv8HxUVgnQ=&oauth_signature_method=HMAC-
> SHA1&oauth_timestamp=1285074160&oauth_version=1.0screen_name=.....&user_id=......&text=UpdateMyTwitter
> 
> After this it will open a new Window, where I enter my user data and
> then I get an error.
> 
> <?xml version="1.0" encoding="UTF-8"?>
> <hash>
>   <request>/1/direct_messages/new.xml</request>
>   <error>Could not authenticate you.</error>
> </hash>
> 
> What is wrong on my request?
> 

-- 
Twitter developer documentation and resources: http://dev.twitter.com/doc
API updates via Twitter: http://twitter.com/twitterapi
Issues/Enhancements Tracker: http://code.google.com/p/twitter-api/issues/list
Change your membership to this group: 
http://groups.google.com/group/twitter-development-talk?hl=en

Reply via email to