There's an oauth_callback in your Base String but not in your
POST/Authorization header.

Tom


On 9/23/10 3:00 AM, bill wrote:
> I have been working on a 401 error from twitter oAuth, but I have no
> clue. Please see if you can help me
> 
> Thanks
> 
> Log
> ===
> 
> debug: token is now:
> debug: token_secret is now:
> debug: Getting request token from http://twitter.com/oauth/request_token
> debug: callback:
> debug: signing request with: HMAC-SHA1
> debug: Signing with base string: POST&http%3A%2F%2Ftwitter.com%2Foauth
> %2Frequest_token&oauth_callback%3D%26oauth_consumer_key
> %3D**********************%26oauth_nonce
> %3D********************************%26oauth_signature_method%3DHMAC-
> SHA1%26oauth_timestamp%3D1285202944%26oauth_version%3D1.0
> debug: Signing with key: *****************************************
> debug: * Connected to tcp://twitter.com:80
> debug: > POST /oauth/request_token HTTP/1.1
> debug: > User-Agent: HTTP_Request2/0.5.2 (http://pear.php.net/package/
> http_request2) PHP/5.3.1
> debug: > Authorization: OAuth realm="http://twitter.com/";,
> oauth_consumer_key="**********************",
> oauth_nonce="********************************",
> oauth_signature="*****************************%3D",
> oauth_signature_method="HMAC-SHA1", oauth_timestamp="1285202944",
> oauth_version="1.0"
> debug: > Host: twitter.com
> debug: > Accept-Encoding: gzip, deflate
> debug: > Content-Length: 0
> debug: >
> debug: < HTTP/1.1 401 Unauthorized
> debug: < date: Thu, 23 Sep 2010 00:49:04 GMT
> debug: < server: hi
> debug: < status: 401 Unauthorized
> debug: < x-transaction: 1285202944-71537-9675
> debug: < last-modified: Thu, 23 Sep 2010 00:49:04 GMT
> debug: < x-runtime: 0.00586
> debug: < content-type: text/html; charset=utf-8
> debug: < pragma: no-cache
> debug: < x-revision: DEV
> debug: < expires: Tue, 31 Mar 1981 05:00:00 GMT
> debug: < cache-control: no-cache, no-store, must-revalidate, pre-
> check=0, post-check=0
> debug: < x-xss-protection: 1; mode=block
> debug: < x-frame-options: SAMEORIGIN
> debug: < vary: Accept-Encoding
> debug: < content-encoding: gzip
> debug: < content-length: 62
> debug: < connection: close
> debug: <
> debug: Failed to validate oauth signature and token
> debug: * Disconnected
> Net_URL2 Object ( [_options:Net_URL2:private] => Array ( [strict] => 1
> [use_brackets] => 1 [encode_keys] => 1 [input_separator] => &
> [output_separator] => & ) [_scheme:Net_URL2:private] => http
> [_userinfo:Net_URL2:private] => [_host:Net_URL2:private] =>
> twitter.com [_port:Net_URL2:private] => [_path:Net_URL2:private] => /
> oauth/request_token [_query:Net_URL2:private] =>
> [_fragment:Net_URL2:private] => )
> ------- In exception block -------ERROR: Failed getting token and
> token secret from response
> 

-- 
Twitter developer documentation and resources: http://dev.twitter.com/doc
API updates via Twitter: http://twitter.com/twitterapi
Issues/Enhancements Tracker: http://code.google.com/p/twitter-api/issues/list
Change your membership to this group: 
http://groups.google.com/group/twitter-development-talk

Reply via email to