and while i use the GET request, it response the same result.

GET request:

my url, prm(parameters) as following:

char *tweet_retweets_response = NULL;

debug trace: tweet_retweets_url =
http://twitter.com/statuses/retweets/25293485057.xml?oauth_consumer_key=95Sw32n3TIUKtE8U4kbA&oauth_nonce=iup8Ydi44p4Vaujb8a9bo&oauth_signature_method=HMAC-SHA1&oauth_timestamp=1285242911&oauth_token=172312929-C4kebETEWK2XWA8dCzoSMRcKMDdnecg3be2EqsTr&oauth_version=1.0&oauth_signature=GNSdETwJzEVSr145hCJvG8vXH2M%3D
debug trace: tweet_retweets_prm = (null)

and call:
tweet_retweets_response = oauth_http_get(tweet_retweets_url,
tweet_retweets_prm);

and the response is:
debug trace: tweet_retweets_response = <?xml version="1.0"
encoding="UTF-8"?>
<statuses type="array">
</statuses>

and then return to my web, the tweet(status_id = 25293485057) doesn't
be retweeted, why?

-------------------------------------------------------------------------------------------------------------------------
2010/9/23 yuzhujiutian <yuzhujiut...@gmail.com>

> hi all:
>
> my url, prm(parameters) as following:
>
> char *tweet_retweets_response = NULL;
>
> debug trace: tweet_retweets_url =
> http://api.twitter.com/1/statuses/retweets/25293485057.xml
> debug trace: tweet_retweets_prm =
>
> oauth_consumer_key=**********************&oauth_nonce=UuG5RuilHNOJWdbcM5iS&oauth_signature_method=HMAC-
>
> SHA1&oauth_timestamp=1285241013&oauth_token=**********************&oauth_version=1.0&oauth_signature=gSAo
> %2BWTyQauzludvPD%2Fz8UrhfDw%3D
>
> and call:
> tweet_retweets_response = oauth_http_post(tweet_retweets_url,
> tweet_retweets_prm);
>
> and the response is:
> debug trace: tweet_retweets_response = <?xml version="1.0"
> encoding="UTF-8"?>
> <statuses type="array">
> </statuses>
>
> and then return to my web, the tweet(status_id = 25293485057) doesn't
> be retweeted, why?

-- 
Twitter developer documentation and resources: http://dev.twitter.com/doc
API updates via Twitter: http://twitter.com/twitterapi
Issues/Enhancements Tracker: http://code.google.com/p/twitter-api/issues/list
Change your membership to this group: 
http://groups.google.com/group/twitter-development-talk

Reply via email to