I want to integrate twitter in my iOS application so users can do
basic tweets.  I got some source code from a developer that basically
takes care of everything.  When running their source code, with their
consumer key and secret, everything works perfectly when I try to
login using an existing twitter account.

So I went to dev.twitter.com, and registered my own app.  I registered
as a client app (not browser), and Read&Write access.  After
submitting, I got my new consumer key and consumer secret and plugged
it into the same code base instead of the previous developer's info.
When I then tried to login using the same exact twitter account, I get
an error from twitter to check the username and password.

I print the following error to the console:

Error: Error Domain=NSURLErrorDomain Code=-1012 "The operation
couldn’t be completed. (NSURLErrorDomain error -1012.)"
UserInfo=0x605e3c0 {NSErrorFailingURLKey=https://api.twitter.com/oauth/
access_token, NSErrorFailingURLStringKey=https://api.twitter.com/oauth/
access_token, NSUnderlyingError=0x6057210 "The operation couldn’t be
completed. (kCFErrorDomainCFNetwork error -1012.)"}

I don't know how the previous developer's account was setup, so I
don't know what I'm doing wrong.  I'm guessing something is wrong with
the account and how it's setup because I also downloaded the
XAuthTwitterEngineDemo and used the previous developers account
settings and everything worked.  When I plugged in my consumer key and
secret, once again it fails to login.

I have tried googling this error, but I'm just not finding what could
possible be wrong.  Any help would be much appreciated.

Twitter developer documentation and resources: http://dev.twitter.com/doc
API updates via Twitter: http://twitter.com/twitterapi
Issues/Enhancements Tracker: http://code.google.com/p/twitter-api/issues/list
Change your membership to this group: 

Reply via email to