Hi there,

Based on the instructions at: https://gist.github.com/564882, I am trying to
set up the TwitterOAuth object, but I seem to be falling at the first
hurdle, even before I try authenticating another user.

With the code:

<pre>
<?php
        error_reporting(E_ALL);
        require_once('twitteroauth/twitteroauth.php');
        require_once('config.php');
        $t = new TwitterOAuth(CONSUMER_KEY, CONSUMER_SECRET, OAUTH_TOKEN,
OAUTH_TOKEN_SECRET);

        print_r($t);
        $v = $t->get('account/verify_credentials');
        print_r($v);
?>
</pre>

I am getting the following output:

TwitterOAuth Object
(
    [http_code] =>
    [url] =>
    [host] => https://api.twitter.com/1/
    [timeout] => 30
    [connecttimeout] => 30
    [ssl_verifypeer] =>
    [format] => json
    [decode_json] => 1
    [http_info] =>
    [useragent] => TwitterOAuth v0.2.0-beta2
    [sha1_method] => OAuthSignatureMethod_HMAC_SHA1 Object
        (
        )

    [consumer] => OAuthConsumer Object
        (
            [key] => <apparently correct>
            [secret] => <apparently correct>
            [callback_url] =>
        )

    [token] => OAuthConsumer Object
        (
            [key] => <apparently correct>
            [secret] => <apparently correct>
            [callback_url] =>
        )

)

As you can see, I am not getting the methods 'get', 'post' etc. in my object
$t when I instantiate it, and I can go no further.

I'm confuzzled, and would be grateful for any tips!

Dave

-- 
Twitter developer documentation and resources: http://dev.twitter.com/doc
API updates via Twitter: http://twitter.com/twitterapi
Issues/Enhancements Tracker: http://code.google.com/p/twitter-api/issues/list
Change your membership to this group: 
http://groups.google.com/group/twitter-development-talk

Reply via email to