Hello Nik,

I was in between 2 smaller projects so I taked the time to download
again. Seems nice, only I could not test the application since you
listen on a specific IP address instead of ''.

So I opened project, ignored all components I do not have, removed the
units I do not have and run.

2 things are wrong in your server:
- you forget to assigne your own ClientClass to the server
- you destroy the server in form's OnClose and you cannot because the
  component is sitting on the form.

So right before you call WSocketServer1.Listen; you do:
WSocketServer1.ClientClass := TcpClient;

And comment this line:

I no AV's, every button I click on client sends 1 byte to server. Seems
all OK to me. Can you tell if this worked ?

Rgds, Wilfried

Tuesday, May 10, 2005, 08:37, [EMAIL PROTECTED] wrote:

> Still getting errors on my tcp part. Uploaded my project on a
> server, perhaps if anybody want to take al look at it.

> http://japnik.be/Project/

> ServerAppl. Should be a simulator of a robot (btw need glscene to view it 
> work :s)
> ClientAppl. Remote control for that simulater

> Problem: pretty weird i can tell you. I start my computer, first
> time I open my project it won't work. When the client logs in i
> recieve an error about an acces violation. I delete my menu, close my
> project without saving, reopen it. and yes indeed now it works.
> getting nuts here :0P.

> When i then add a memo box en restart the program, i ones again
> recieve an error when the client tries to log in. Didn't add any code,
> only a memo box.

> I'm pretty stuck here, so all the help is welcome.

To unsubscribe or change your settings for TWSocket mailing list
please goto http://www.elists.org/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to