> client socket event) and then start de connect of the smtp, but,
> the other commands of the smtp occurs out of the event of the
> socket client. I put a delayed call to the smtp.connect (to
> occurs outside the event) and...magic! works...
> well, don´t understand why, anyway, I will test more, but
> it´s working now...

I'm not sure I fully understand your program's logic. But instead of the delay, 
I would use a custom
message to queue the request which will be executed cleanly after all current 
events and subroutines
are done.
--
[EMAIL PROTECTED]
http://www.overbyte.be

----- Original Message ----- 
From: "Moacir Flávio Gonçalves" <[EMAIL PROTECTED]>
To: "ICS support mailing" <twsocket@elists.org>
Sent: Monday, June 13, 2005 11:13 PM
Subject: Re: [twsocket] SMTPCli within a NT service - stack overflow


> Well, I think I found the problem. When I write a small application it works
> fine. But in my software it isn´t...
> The app is a server and have a listening socket, a client socket and a smtp
> client. When a client of the app
> send a message, the app sends a request of data to another app (data base)
> and saves a callback function
> for answer de client when DB answers... When DB answer, the app call the
> callback function (inside the
> client socket event) and then start de connect of the smtp, but, the other
> commands of the smtp occurs out
> of the event of the socket client. I put a delayed call to the smtp.connect
> (to occurs outside the event) and...
> magic! works... well, don´t understand why, anyway, I will test more, but
> it´s working now...
> Flavio
>
> Rm 12:2 - "E não vos conformeis com este século, mas transformai-vos pela
> renovação da vossa mente, para que experimenteis qual seja a boa, agradável
> e perfeita vontade de Deus."
>
> ----- Original Message ----- 
> From: "Moacir Flávio Gonçalves" <[EMAIL PROTECTED]>
> To: "ICS support mailing" <twsocket@elists.org>
> Sent: Monday, June 13, 2005 1:17 PM
> Subject: Re: [twsocket] SMTPCli within a NT service - stack overflow
>
>
> > Good! I will, but, meanwhile, I use delphi 7, no update...
> > I´ll make a version available
> > Thanks
> > Flavio
> >
> > Rm 12:2 - "E não vos conformeis com este século, mas transformai-vos pela
> > renovação da vossa mente, para que experimenteis qual seja a boa,
> > agradável e perfeita vontade de Deus."
> >
> > ----- Original Message ----- 
> > From: "Francois PIETTE" <[EMAIL PROTECTED]>
> > To: "ICS support mailing" <twsocket@elists.org>
> > Sent: Monday, June 13, 2005 1:00 PM
> > Subject: Re: [twsocket] SMTPCli within a NT service - stack overflow
> >
> >
> > No idea.
> > Can you write a very small test program that reproduce your problem ?
> > btw: I use SMTP in service apps without any problem.
> >
> > --
> > [EMAIL PROTECTED]
> > http://www.overbyte.be
> >
> > ----- Original Message ----- 
> > From: "Moacir Flávio Gonçalves" <[EMAIL PROTECTED]>
> > To: <twsocket@elists.org>
> > Sent: Monday, June 13, 2005 1:42 PM
> > Subject: [twsocket] SMTPCli within a NT service - stack overflow
> >
> >
> >> The HTTPCli 401 problem (triggered twice is resolved, thanks a lot)...
> >> Now I'm experiencing another "problem" with a SMTP. It's inside a NT
> >> service.
> >> The problem occurs after I send any email, in another thread then the
> >> current one. It's like if a message was sent but with any kind of
> >> problem,
> >> because the thread goes stack overflow, calling again and again with
> >> parameters 0,0,0 (have look at the call stack), like if a message "nil"
> >> or some
> >> kind of was sent, don't know; I do not get when its triggered yet...
> >> but I'm looking into... I´m thinking it´s about the WndProc of the
> >> SMTPCli,
> >> because the problem trigger only after I send a email
> >> Someone has a clue?
> >>
> >> Flavio
> >>
> >>
> >>
> >> Rm 12:2 - "E não vos conformeis com este século, mas transformai-vos pela
> >> renovação da vossa mente, para que experimenteis qual seja a boa,
> >> agradável e perfeita vontade de Deus."
> >> -- 
> >> To unsubscribe or change your settings for TWSocket mailing list
> >> please goto http://www.elists.org/mailman/listinfo/twsocket
> >> Visit our website at http://www.overbyte.be
> >>
> >
> >
> > -- 
> > To unsubscribe or change your settings for TWSocket mailing list
> > please goto http://www.elists.org/mailman/listinfo/twsocket
> > Visit our website at http://www.overbyte.be
> >
> >
> >
> > -- 
> > To unsubscribe or change your settings for TWSocket mailing list
> > please goto http://www.elists.org/mailman/listinfo/twsocket
> > Visit our website at http://www.overbyte.be
> >
> >
>
>
> -- 
> To unsubscribe or change your settings for TWSocket mailing list
> please goto http://www.elists.org/mailman/listinfo/twsocket
> Visit our website at http://www.overbyte.be
>


-- 
To unsubscribe or change your settings for TWSocket mailing list
please goto http://www.elists.org/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to