Use UrlEncode function.

--
Contribute to the SSL Effort. Visit
http://www.overbyte.be/eng/ssl.html
--
[EMAIL PROTECTED]
Author of ICS (Internet Component Suite, freeware)
Author of MidWare (Multi-tier framework, freeware)
http://www.overbyte.be


----- Original Message ----- 
From: "Public" <[EMAIL PROTECTED]>
To: <twsocket@elists.org>
Sent: Tuesday, September 20, 2005 11:27 AM
Subject: [twsocket] HTTPCli.Post - removing spaces!


> Hello,
>
> I am using HTTPCli to post data to a web-site.
>
> Example code is:
>
>     sData :=  'CustomerNo=' + MainWnd.FCustomerNumber + '&' +
>               'Pwd=' + MainWnd.FPwd + '&' +
>               'Subject='  + dbEditSubject.Text;
>
>     HttpCli1.SendStream := TMemoryStream.Create;
>     HttpCli1.SendStream.Write(sData[1], Length(sData));
>     HttpCli1.SendStream.Seek(0, 0);
>     HttpCli1.RcvdStream := TMemoryStream.Create;
>     HttpCli1.URL := MainWnd.FBaseURL + 'postmessage.asp';
>     HttpCli1.Post;
>
>
> I am using the default encode type, ContentTypePost:
> application/x-www-form-urlencoded
>
>
>
> PROBLEM / QUESTION:
> My data that are posted may contains spaces (Subject=Bla bla bla).
> When reviewing the data, all spaces has been removed.
>
> I have tested posting the same data via a web-form to the same
> web-script. This works fine. The spaces are there.
>
> What do I do wrong?
>
>
> Regards,
>
> Perry J├Ânsson
>
>
>
> -- 
> To unsubscribe or change your settings for TWSocket mailing list
> please goto http://www.elists.org/mailman/listinfo/twsocket
> Visit our website at http://www.overbyte.be

-- 
To unsubscribe or change your settings for TWSocket mailing list
please goto http://www.elists.org/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to