I have built a BCB5 VCL control using an array of TWSocket's.
Naturally when my class gets built it calls new on each TWSocket
instance it needs..

I am getting an EAbstractError exception in the following code.

constructor TCustomLineWSocket.Create(AOwner: TComponent);
begin
    inherited Create(AOwner);
    FLineEnd  := #13#10;                <--- highlighted line..
    FLineMode := FALSE;
end;

I don't understand why this is a problem. 
All references to this indicate it is coming from sysutils.

Perhaps there is a known solution. 

--------------------------------
Bart Thompson
--------------------------------


-- 
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.344 / Virus Database: 267.11.14/128 - Release Date:
10/10/2005
 



-----------------------------------------
The information contained in this message is proprietary of Amdocs,
protected from disclosure, and may be privileged. The information is
intended to be conveyed only to the designated recipient(s) of the message.
If the reader of this message is not the intended recipient, you are hereby
notified that any dissemination, use, distribution or copying of this
communication is strictly prohibited and may be unlawful. If you have
received this communication in error, please notify us immediately by
replying to the message and deleting it from your computer.
-- 
To unsubscribe or change your settings for TWSocket mailing list
please goto http://www.elists.org/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to