TnClient is behaving the same strange way. TnClient displays: "Connecting to
xxx.xxx.xxx.xxx" and then "Connected" but the welcome banner of the server
is displayed with 20-30 secs delay. On the other machine, the welcome banner
is displayed right after "Connected".

My gues is it can be an OS bug, on the specific hardware platform (ethernet
NIC, etc.).

I've downloaded a packet sniffer, and 3 packets are captured when the
connection is initialized: one from the client to the server, one from the
server to the client and again, one from the client, and then the data
transfer is delayed.

The server is build around ucspi-tcp from http://cr.yp.to, on linux. On
short, the "tcpserver" program is listening on a specified port and when a
connection is established they launch an external program, rewriting
input/output filedescriptors of that program on the incoming socket. It
works very well, as it is also used for the (*nix users wellknowed) "qmail".

10x again,
/ Ionut Muntean

-----Original Message-----
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On
Behalf Of Francois PIETTE
Sent: 6 decembrie 2005 07:56 PM
To: ICS support mailing
Subject: Re: [twsocket] Strange

> The telnet connection on the specified port on the server is working well.
> :(

OK, so let's try with one of the ICS provided demos so that we are sure you
have not a bug in your own code. Use TnClient for example.

--
Contribute to the SSL Effort. Visit http://www.overbyte.be/eng/ssl.html
--
[EMAIL PROTECTED]
http://www.overbyte.be



----- Original Message -----
From: "Ionut Muntean" <[EMAIL PROTECTED]>
To: "'ICS support mailing'" <twsocket@elists.org>
Sent: Tuesday, December 06, 2005 4:51 PM
Subject: Re: [twsocket] Strange


> The telnet connection on the specified port on the server is working well.
> :(
>
> / Ionut Muntean
>
> -----Original Message-----
> From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On
> Behalf Of Francois Piette
> Sent: 6 decembrie 2005 05:23 PM
> To: ICS support mailing
> Subject: Re: [twsocket] Strange
>
>> I'm experiencing a strange behavior of WSocket.Connect ->
>> WSocket.OnSessionConnected. I have 2 PC. One on which I develop my
>> applications and a laptop. Both of them are Windows XP Proffesional
>> with SP2 installed. The server my application is connecting is on the
>> same 100 Mbps LAN as the 2 PC's above. From the firs PC, after calling
>> WSocket.Connect, the connection is established very fast and
>> OnSessionConnected is called. On the second PC, after calling Connect,
> nothing happens for about 30 seconds.
>> The server the application is connecting does no receive any
>> connection for the time specified above. So, to resume, on the first
>> PC the connection is established right after WSocket.Connect and on
>> the second PC the connection is established after an anoying delay.
>> Does someone experience any similar situation? I have tried
>> wsoTcpNoDelay on both server and client. No results.
>> Please help.
>
> I could be a DNS problem. Try connecting by specifying the IP address
> instead of hostname to be sure it is not a DNS problem.
> What is the ping time ? Try ping using the IP address and ping using the
> hostname.
> Try using the command line telnet to connect to your server:
>    telnet your_server_name your_server_port If it is slow also, then
> defenitely there is a problem within the OS, I guess a DNS problem.
>
> --
> Contribute to the SSL Effort. Visit
> http://www.overbyte.be/eng/ssl.html
> --
> [EMAIL PROTECTED]
> Author of ICS (Internet Component Suite, freeware) Author of MidWare
> (Multi-tier framework, freeware) http://www.overbyte.be
>
>
> --
> To unsubscribe or change your settings for TWSocket mailing list please 
> goto
> http://www.elists.org/mailman/listinfo/twsocket
> Visit our website at http://www.overbyte.be
>
> -- 
> To unsubscribe or change your settings for TWSocket mailing list
> please goto http://www.elists.org/mailman/listinfo/twsocket
> Visit our website at http://www.overbyte.be 

-- 
To unsubscribe or change your settings for TWSocket mailing list
please goto http://www.elists.org/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

-- 
To unsubscribe or change your settings for TWSocket mailing list
please goto http://www.elists.org/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to