No, it's in the stream alright. As I said, it's some html code. I
studied it a bit closer and it's a redirect. I come from Indy and that
handled redirects automatically (but I extremly dislike their
blocking), so am now browsing ICS's help file (google :) to find out
how to enable redirects in HttpCli. I assume that'll fix the problem.

PS: if ever a help file is made available for ICS, I am willing to pay
for it as it would safe me a lot of time.

Mike

On 6/19/06, Francois PIETTE <[EMAIL PROTECTED]> wrote:
> It is likely that you haven't cleared the stream used to receive data for a
> previous request.
>
> --
> [EMAIL PROTECTED]
> http://www.overbyte.be
>
> ----- Original Message -----
> From: "Mike Versteeg" <[EMAIL PROTECTED]>
> To: <twsocket@elists.org>
> Sent: Monday, June 19, 2006 11:37 AM
> Subject: [twsocket] html code in downloaded file
>
>
> > Hi,
> >
> > I am trying to download a file using HttpCli and TFileStream, but the
> > downloaded file has some html code inserted in front of the actual
> > binary data (announcing the data in plain text). Is there an easier
> > way to remove this than by examining and removing it? I notice IE
> > saves the file without the html code..
> >
> > Thanks,
> >
> > Mike
> > --
> > To unsubscribe or change your settings for TWSocket mailing list
> > please goto http://www.elists.org/mailman/listinfo/twsocket
> > Visit our website at http://www.overbyte.be
>
> --
> To unsubscribe or change your settings for TWSocket mailing list
> please goto http://www.elists.org/mailman/listinfo/twsocket
> Visit our website at http://www.overbyte.be
>
-- 
To unsubscribe or change your settings for TWSocket mailing list
please goto http://www.elists.org/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to