> Markus Humm wrote:
>> I've tried the FTPTst Application right now and found out that a PASS
>> is required after a open, it will delete the file then. But why
>> didn't the server tell me in my program and always claimed to have
>> carried out my delete request?
> If authentication is required to issue a command the server should send
> an error code, typically 530.

Okay, will pay attention to it. Is there any short overview of the
FTP-protocols available? Afaik the RFCs are a bit longish I fear.

>> Doesn't really matter, because the put still only works for the second
>> time. 
> No problem here using FtpTst demo and FileZilla server.
>> As I noticed he tries to open a binary connection although I
>> left "binary mode" unchecked.
> In order to set transfer mode you must set property BinaryMode to TRUE
> as well as issue command TypeSet to send the transfer type command to
> the server. Same when switching back to ascii except property BinaryMode
> must be set to FALSE before issuing the TypeSet command.   

Okay, didn't know that. Will try out that typeset command. But why has
FtpCli a property for transfer mode then anyway?
>> What's happening here? I'll need a
>> binary transfer later, but not at this time.
>> Why the need of a 2nd put? Why does the first one fail? Is it my
>> FTPServer?
> Very unlikely, try to upload with FtpTst demo first. If that works
> the problem should be in your code.

I've tried that and the very same happens here!
I'll try the mentioned things above (might take some days) and report back.



To unsubscribe or change your settings for TWSocket mailing list
please goto http://www.elists.org/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to