Are you using TCP or UDP protocol ?
UDP is unreliable by design but faster. With UDP, you query or its answer
may be lost.
It is also possible that the target DNS server is overflowed.

Contribute to the SSL Effort. Visit http://www.overbyte.be/eng/ssl.html
--
[EMAIL PROTECTED]
Author of ICS (Internet Component Suite, freeware)
Author of MidWare (Multi-tier framework, freeware)
http://www.overbyte.be


----- Original Message ----- 
From: "Max Terentiev" <[EMAIL PROTECTED]>
To: "ICS support mailing" <twsocket@elists.org>
Sent: Friday, September 15, 2006 12:00 PM
Subject: [twsocket] Different results for one DNS Query


> Hello,
>
> I notice strange problem:
>
> I use TDNSQuery for resolving MX servers for e-mail addresses.
>
> Time to time TDNSQuery may return empty result (ResponseANCount==0) for
> domain.
>
> But next time for SAME domain it may return MX servers (ResponseANCount>0)
>
> Why fist time ResponseANCount is zero but second time is not zero ?
>
> I use same DNS server for both queries.
>
> It's probably bug in my application ? Or DNS server may return wrong
result time to time
> (in case of overloading, etc) ??
>
> ---
> With best regards, Max Terentiev.
> Business Software Products.
> AMS Development Team.
> [EMAIL PROTECTED]
>
> -- 
> To unsubscribe or change your settings for TWSocket mailing list
> please goto http://www.elists.org/mailman/listinfo/twsocket
> Visit our website at http://www.overbyte.be

-- 
To unsubscribe or change your settings for TWSocket mailing list
please goto http://www.elists.org/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to