Dod wrote:
> Hello Arno,
> 
> I see in the log that there is 5 seconds delay between DATA and the
> 10054 error. This may be interesting.

No, the delay is 2 minutes and 5 seconds.
One thing I can imagine is a problem with MTU Discovery,
since small packets (SMTP command/response) go thru,
may be the required ICMP packets are filtered?
Does someone know what has to be configured to ensure MTU Discovery
will not fail?

--
Arno Garrels
  

 
> During  this  delay  do you send data ? I say this because some server
> will  close cnx if no data transmitted fast enought and do not receive
> data for xx seconds, usually the timeout is between 1 or 3 minutes but
> I know a server that wait only 3 seconds (may be bad configuration).
> 
> The  best  is  to ask client to manualy telnet port 25 into the server
> and  type  a  SMTP  sequence and wait 5 seconds betweent each line you
> type.
> 
> Also may be there is some "check-back" cnx to the client's machine and
> if FW is ON then machine cannot be "checked".
> 
> regards.
> 
> AG> One of my customers reported problems sending mail with an
> TSmtpCli AG> application when the Windows firewall is turned on.
> Strange is that AG> sending mail data fails for some reason and the
> server drops the AG> connection after ~2 minutes (of inactivity) even
> though port 25 AG> is explicitely opened.
> 
> AG> First log is with firewall turned off, mail is sent successfully,
> AG> second log with firewall turned on and port 25 explicitely opened:
> 
> AG> 01.01.08 2:22:47 PM < MAIL FROM:<[EMAIL PROTECTED]>
> AG> 01.01.08 2:22:48 PM > 250 2.1.0 <[EMAIL PROTECTED]>... Sender ok
> AG> 01.01.08 2:22:48 PM < RCPT TO:<[EMAIL PROTECTED]>
> AG> 01.01.08 2:22:48 PM > 250 2.1.5 <[EMAIL PROTECTED]>... Recipient ok
> AG> 01.01.08 2:22:48 PM < DATA
> AG> 01.01.08 2:22:48 PM > 354 Enter mail, end with "." on a line by
> itself AG> 01.01.08 2:22:48 PM < .
> AG> 01.01.08 2:22:48 PM > 250 2.0.0 m01JMoVp009311 Message accepted
> for delivery AG> 01.01.08 2:22:48 PM < QUIT
> AG> 01.01.08 2:22:48 PM > 221 2.0.0 ms-smtp-xyz.com closing connection
> 
> 
> AG> 01.01.08 4:43:40 PM < MAIL FROM:<[EMAIL PROTECTED]>
> AG> 01.01.08 4:43:41 PM > 250 2.1.0 <[EMAIL PROTECTED]>... Sender ok
> AG> 01.01.08 4:43:41 PM < RCPT TO:<[EMAIL PROTECTED]>
> AG> 01.01.08 4:43:41 PM > 250 2.1.5 <[EMAIL PROTECTED]>... Recipient ok
> AG> 01.01.08 4:43:41 PM < DATA
> AG> 01.01.08 4:43:41 PM > 354 Enter mail, end with "." on a line by
> itself AG> 01.01.08 4:45:46 PM < Error=10054 Session aborted!
> 
> AG> Adding the application to the exception list makes no difference.
> AG> Anybody any idea?
> 
> AG> --
> AG> Arno Garrels
-- 
To unsubscribe or change your settings for TWSocket mailing list
please goto http://lists.elists.org/cgi-bin/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to