Although I was a contributor ICS SSL, I haven't really got to play
with it. I gave it a try last night with V6 and had a few questions.

1. I see two sets of .bdsproj files in Vc32 folder, one with Ssl
in the file names and have USE_SSL;USE_ZLIB_OBJ defined, one without.
Should I install both to use wsocket with and with SSL at the same
time? I installed the copy with SSL and it looks like I'm getting
both the SSL and non-SSL components so I suppose the SSL version
is a super set?

2. I first installed OpenSSL 0.9.8.h on my Windows XP machine but
none of the tools ran. (Windows can not execute ... error) then I
installed 0.9.8.e and thing worked fine. Is this a know issue?

3. After I generated the cert files, HttpsTst demo worked fine. My
question here is, is there an easy way to use an embedded cert and key
string, as opposed to external files? I notice that the SslContext
class takes file names.


To unsubscribe or change your settings for TWSocket mailing list
please goto
Visit our website at

Reply via email to