In our product, we have a client/server GUI that uses HTTPS to POST XML for
administration. Both the client and the server uses ICS. In the past, the
client was using Wininet which was working perfectly. The issue is strange
because it does not happen when the computer is rebooted and the client and
server are run for the first time. When I re-run the client against the
server, winsock error 10053 occurs. I first guessed it was due to OpenSSL
and the self-signed certificate we are using. When I restart the server and
the client, it happens too! (That is the strange thing.) It only works when
the machine is rebooted. I tried changing the OpenSSL DLL names separately

The machine is a 32-bit Windows 2008 R1 SP2. It works perfectly on Win2008R2
x64 and Win7Pro x64. It has always worked on Win7 but I believe I have had
to turn off keep-alive for it to work on Win2008R2.

You can see it (blackbox) here:
http://www.fastream.com/beta/IQProxyServer.exe (sorry, closed-source)

Any help will be appreciated.


To unsubscribe or change your settings for TWSocket mailing list
please goto http://lists.elists.org/cgi-bin/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to