Hi,

I have a high security email program that I'm trying to correct for
POODLE in. It also uses https. There are some security experts working
with me.

I was requested to use this cipher suite:
ALL:!ADH:!MD5:!SSLv3:+TLSv1.2:@STRENGTH

The problem is, I receive this ssl log error:
16:20:54:753 02DB1CA0  644  [12] error:140830B5:SSL
routines:SSL3_CLIENT_HELLO:no ciphers available

I've tried to use this suite:
ALL:!ADH:!MD5:!SSLv3:+TLSv1.2:@STRENGTH (using !SSLv2 instead of !SSLv3)

With this I set SSL options:
sslOpt_NO_SSLV2, sslOpt_NO_SSLV3

with SslVersionMethod to
sslTLS_V1 (also tried sslTLS_V1_client and sslTLS_V1_server)

This works, but in the ssl log I get:
16:30:55:780 03800720 SslHandshakeDone(0) 652. Secure connection with
TLSv1, cipher ECDHE-RSA-AES256-SHA, 256 secret bits (256 total), session
reused=False

This says TLSv1. I need TLSv1.2.

I really need to implement the cipher suite that I was given.

What could be my problem?

Thanks so much!

George

-- 
To unsubscribe or change your settings for TWSocket mailing list
please goto http://lists.elists.org/cgi-bin/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to