I also find that v8.44 does not build with C++ Builder 2007 (yes we still use it)
- the problem being the newly introduced variables such as:
static const HRESULT TRUST_E_NOSIGNATURE = -2146762496;

any suggestions would be appreciated
Paul

On 04/04/2017 09:31, Noam Weissman wrote:
Hi Jarek,

That would be great :-)

Waiting for you update !

Many thanks,
Noam.

-----Original Message-----
From: TWSocket [mailto:twsocket-boun...@lists.elists.org] On Behalf Of Jarek 
Karciarz
Sent: Tuesday, April 04, 2017 11:08 AM
To: ICS support mailing; Angus Robertson - Magenta Systems Ltd
Subject: Re: [twsocket] Latest ICS 8.44 and C++Builder 10.2

Hi
Regarding errors in overbyteIcsUtils.pas they occur only under c++. I have 
fixed them. I will post the changes here today evening.
Hopefully Angus could update the file so that future releases are not affected. 
For now after every release I need to update the file on myself.
Regarding 10.2 c++  usage I cannot say much right now. Currently I have 
successfully compiled and installed vcl only packages. But I didn't use them 
yet as I have problem with other package.
After fixing other package I can eventually confirm ics usage for c++ 10.2

Pozdrawiam

Jarek Karciarz



----------
Od: Angus Robertson - Magenta Systems Ltd <an...@magsys.co.uk>
Data: 4 kwietnia 2017 09:36:19
Do: twsocket@lists.elists.org
Temat: Re: [twsocket] Latest ICS 8.44 and C++Builder 10.2

I have installed C++Builder 10.2 and triad to add the ICS components.
I got a few errors like Duplicated components FMX etc_
Sorry, as the readme and download pages clearly state, the last C++
release ICS officially supported was XE3 for which packages are
available.

None of the current ICS maintainers have C++ experience, so we can not
test ICS on C++.

A couple of users in this mailing list have said they have got recent
c++ versions working, but no-one has been able to supply all the
missing packages necessary for a distribution.

Without C++ volunteers, there will be no C++ version.  If anyone here
can build packages for C++ 10 or later, please update the latest
nightly V8 zip with all the files and changes necessary, and I'll add
the changes to SVN.  A few emailed files is not sufficient.

Angus

--
To unsubscribe or change your settings for TWSocket mailing list
please goto http://lists.elists.org/cgi-bin/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

--
To unsubscribe or change your settings for TWSocket mailing list please goto 
http://lists.elists.org/cgi-bin/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

--
*Paul Read*
Partner
nSolve Ltd <http://www.nsolve.com/?empr>
Tel: +44 (0)1993 402011
Tel (US): +1 617 273 2304
nSolve <http://www.nsolve.com/?empr>
nCall <http://www.nsolve.com/nCall-overview.shtml?empr>

--
To unsubscribe or change your settings for TWSocket mailing list
please goto http://lists.elists.org/cgi-bin/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to